Mac OS: Game starts but does not show after Resolution Chang

Post your woes here and we will do our best to sort them out

Moderator: Admins

Post Reply
Posts: 3
Joined: Fri Dec 02, 2011 2:45 pm

Mac OS: Game starts but does not show after Resolution Chang

Post by emotionengine » Fri Dec 02, 2011 3:15 pm

Game starts but does not show after changing the screen resolution.

I have been running Frozen Synapse on Mac OS X Lion without any problems in fullscreen mode until recently when I tried to record a match for YouTube. Because I was running the game at 1440x900 resolution in fullscreen mode, the game offered the option of changing the resolution to 1280x720 for the purposes of recording the match. As soon as I clicked 'OK', the game window disappeared, and I was thrown back to the desktop, although the game still seemed to be running in the background. I couldn't get the game window to reappear, so I manually quit by right clicking on the Frozen Synapse icon on the dock. I restarted the game and I could hear the game sounds and music and the voice prompting me to log in, but there was no application window, just the icon on the dock. I am using the Steam version of the game. I deleted the game and re-installed, to no avail.

I then tried to change the resolution via the methods mentioned in other threads by manually editing the preferences file. I don't know if it's because I'm running the Mac version but my preferences file had a different name and the content was different to the one mentioned elsewhere. I couldn't find the lines for changing to windowed mode or even manually editing the resolution in my file.

I'm stumped at this point. Deleting and re-installing the game won't help. Any ideas?

EDIT: I just realised I have the same problem that is mentioned in this thread (I didn't see it earlier): viewtopic.php?f=21&t=3670 except I'm running the Steam version, the preferences folder for the game seems to be located elsewhere, deleting what I think it is in the Steam version has no effect and re-installing doesn't solve the problem.
Posts: 5
Joined: Sun Dec 04, 2011 3:41 am

Re: Mac OS: Game starts but does not show after Resolution C

Post by anoshi » Sun Dec 04, 2011 4:03 am

I feel ya! Lost a good part of my Sunday trying to work out this one too (macbook pro).

The fix! (This will probably work for owners of the non-steam version too, as it's just the mac equivalent of windows' "alt-enter" fullscreen toggle. No more wiping your saves!)

1) Use "command + enter" to switch the game into windowed mode (i.e. press the "command" and "enter" (AKA "return") keys at the same time)

- you should now be able to see the game. If not, try "command" + "tab" to cycle through your running apps and stop on the Frozen Synapse icon to give the game focus.

2) Choose to Play Offline, and from this GUI you can head into Options, where you'll see the 1280x720 resolution was being forced
3) Set your desired res (tick fullscreen first and you'll get a full array of modes, not just 800x600 waa!), Apply your changes and
4) Get back into the games :-)

For mode7crew, the following is the offending snippet from my console.log. Note the 1280x720 is being forced (neither my macbook nor desktop monitor can display this resolution, hence the GUIs aren't showing but the game is there).
(185:) set screen mode 1280 x 720 x -1339538740, fullscreen, force it, dont repaint
Cleaning up the display device...
Killing the texture manager...
Clearing the current AGL context...
Clearing the current drawable...
Deleting the rendering context...
>> Attempting to change display settings to fullscreen 1280x720x-1339538740...
using display 0x4856080
invalid fullscreen drawable
set AGL fullscreen
Cleared gl buffers
>>Number of FSAA samples is now [1].
Resurrecting the texture manager...
Max Texture Size reported as: 8192
OpenAL Driver Init:
Vendor: Any
Version: OpenAL 1.2
Renderer: Software
(204:) common/gameScripts/audio.cs (57): Unable to find function updateMusicVolume

Confirmed this occurs for mac users when trying to do a local 'youtube' type recording and agreeing to the terms of "we're going to change your resolution, please hold...". Game seems to fall apart and the originally selected res is never restored, making it seem as though the game will never be seen again.

I've used TGB quite a lot over the years so if you'd like to throw me any more mac bugs I'd be happy to take a look. It'll only cost you a little bit of your sourcecode ;-)

Big ups on the game, it's a ripper!
Posts: 3
Joined: Fri Dec 02, 2011 2:45 pm

Re: Mac OS: Game starts but does not show after Resolution C

Post by emotionengine » Sun Dec 04, 2011 8:41 am

Yay, it worked!!

Thank you, anoshi, I had all but given up on this and certainly wasn't expecting such a fast response!

I hope Mode7 takes your efforts into consideration and updates the game accordingly.
Posts: 1
Joined: Wed Jul 30, 2014 2:14 pm

Re: Mac OS: Game starts but does not show after Resolution C

Post by Gredu » Wed Jul 30, 2014 2:15 pm

God bless you anoshi
Post Reply