"Sync Error"

Post your woes here and we will do our best to sort them out

Moderator: Admins

Post Reply
User avatar
Forum Wrangler
Posts: 160
Joined: Wed Apr 11, 2007 5:09 pm
Location: Oxford

"Sync Error"

Post by Jimmeh » Mon Jun 11, 2012 4:08 pm

If you get a 'Sync Error' when trying commit a turn please try exiting to the main menu and reloading the game. This should work for the majority of cases.

In case that doesn't work please make sure the game is running and the affected game is loaded and open the psychoff/data/encounters directory. This is in the following locations (assuming you chose the default installation directory)
  • Windows: C:\FrozenSynapse\psychoff\data\encounters\
  • Windows, Steam: C:\Program Files\Steam\steamapps\common\frozen synapse\psychoff\data\encounters\
    C:\Program Files (x86)\Steam\steamapps\common\frozen synapse\common\frozen synapse\psychoff\data\encounters\
  • OS X: ~/Library/Application Support/FrozenSynapse/psychoff/data/encounters/
  • Linux: ~/.local/share/FrozenSynapse/psychoff/data/encounters/
Find a file named ref<gameid>.enc (replace the <gameid> part with the id of the affected game e.g. ref123456.enc), delete it and try to commit your turn. Don't worry about any other .enc files in this directory.
This should resolve the problem. Please reply if it doesn't, or if you need any help finding this file.
Posts: 17
Joined: Sat Jun 16, 2012 5:43 am

Re: "Sync Error"

Post by eyci » Wed Jul 04, 2012 3:14 pm


I am not sure if this is related, but when I play online FS games, I quite regularly get the following error message when trying to submit a turn:

"... looks like something has gone wrong, you'll need to reload the match ...."

This happens to me maybe once every 5-6 games (I try to be conservative on this estimate).

The first time it happened to me I scoured the forums and one particular solution proposed works for me 100% of the time, which is to ask Steam to "verify the local game files", through which Steam always manages to identify "1 file that failed to validate" and re-downloads it.

I tried your proposed solution once, it worked for the current turn but the error came back the next turn. Then I went back to the Steam method.

My question is, is there anything I can do to address this issue? It has come to a point that now when I submit plans that I worked on for very long, I have to cross my fingers and hope I don't get the error...

P.S. This seems to happen more often when I am in the same game / turn for extended periods of time, maybe ~ 1 hour.

Posts: 1
Joined: Sun Jul 15, 2012 11:05 pm

Re: "Sync Error"

Post by faust06 » Sun Jul 15, 2012 11:43 pm

I'm currently in the 2nd phase of the 2nd mission. When I attempt to Prime my moves, the game crashed when "the shapeforms are deliberating". I've attempted to delete the file as described above, though it's it an offline single player campaign instead of a multiplayer game. I'm currently running on a Mac, and can't seem to figure out why it's happening. I do have the console logs from the crash, but I won't post them here since they're so long. Any help?
Posts: 17
Joined: Sat Jun 16, 2012 5:43 am

Re: "Sync Error"

Post by eyci » Sun Aug 05, 2012 8:18 am


In game UK1 - 591147 I am no longer able to submit a turn due to the ".. something went wrong, we need to reload..." error. I have tried deleting the *.enc file and also reinstalling FS. Just to reiterate, I get this error about once in 5 games or so and usually verifying the Steam files works for me, but not this time.

I'm not sure if this error frequency is considered tolerable by the team and other players, but in case it is not I would appreciate any help in resolving this, thanks.


EDIT: I managed to get the turn to submit. One of the units was behaving weirdly (stuck / unable to give commands), and after messing around with backspace and clicking around it seemed to revert back to normal and the turn went through.
Posts: 1
Joined: Mon Jul 29, 2013 5:30 am

Re: "Sync Error"

Post by silenttex » Mon Jul 29, 2013 5:33 am

I have already done the above steps for my game UK1 - 808265 (a co-op match), but it always does the "... something went wrong, we need to reload..." I tried verifying the game cache for steam and it doesn't work. Please someone help.
Posts: 37
Joined: Wed Apr 10, 2013 8:34 am

Re: "Sync Error"

Post by Kron-OS » Mon Jul 29, 2013 8:40 pm

Hmmm, never head this problem in a coop session, and if I had it in a match, deleting the enc file always helped. I would suggest to email to support@mode7games.com or to stop by in IRC #mode7games and ask MangoFusion if he can help or at least take a look at the match entry in the database.
Posts: 1
Joined: Wed Aug 07, 2013 9:37 am

Re: "Sync Error"

Post by elpres » Wed Aug 07, 2013 9:42 am

Yeah I have this in two co-op games. Both turn 2 on Blue Sunlight : Attack the Chapel. I have tried deleting the file and even reinstalling, using another computer and nothing works.

game numbers are 828717 and 828683. UK1.

Post Reply