[Linux] Segmentation Fault on start (Arch x86_64)

Post your woes here and we will do our best to sort them out

Moderator: Admins

freijon
Posts: 2
Joined: Fri Apr 25, 2014 7:21 pm

[Linux] Segmentation Fault on start (Arch x86_64)

Postby freijon » Fri Apr 25, 2014 7:49 pm

I purchased the complete pack on http://www.frozensynapse.com.

After the installation, I tried running the game. The game does not even start, I get a Segmentation fault right away. Using gdb, I got this output:

Code: Select all

Reading symbols from FrozenSynapse...(no debugging symbols found)...done.
(gdb) r
Starting program: /opt/frozensynapse/FrozenSynapse
warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0xf73f7b40 (LWP 5129)]
[New Thread 0xf677cb40 (LWP 5130)]
[New Thread 0xf3e04b40 (LWP 5134)]

Program received signal SIGSEGV, Segmentation fault.
0x08332aa3 in ?? ()
(gdb) bt
#0  0x08332aa3 in ?? ()
#1  0xf4b8946c in ?? () from /usr/lib32/libLLVM-3.4.so
#2  0xf421e765 in LLVMDisposeMemoryBuffer () from /usr/lib32/libLLVM-3.4.so
#3  0xf5c0d8a0 in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#4  0xf5bfaa10 in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#5  0xf5bfb2d5 in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#6  0xf5c01414 in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#7  0xf5c0153b in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#8  0xf5b01101 in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#9  0xf5b330f2 in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#10 0xf5b1194b in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#11 0xf5bf4fc3 in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#12 0xf5bf533d in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#13 0xf589df28 in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#14 0xf5c1281c in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#15 0xf589f156 in ?? () from /usr/lib32/xorg/modules/dri/radeonsi_dri.so
#16 0xf687a2f3 in ?? () from /usr/lib32/libGL.so.1
#17 0xf6852d84 in ?? () from /usr/lib32/libGL.so.1
#18 0xf684f2ed in ?? () from /usr/lib32/libGL.so.1
#19 0xf684fb6e in glXChooseVisual () from /usr/lib32/libGL.so.1
#20 0xf7f30c84 in ?? () from /usr/lib32/libSDL-1.2.so.0
#21 0xf7f3655b in ?? () from /usr/lib32/libSDL-1.2.so.0
#22 0xf7f36a10 in ?? () from /usr/lib32/libSDL-1.2.so.0
#23 0xf7f22a42 in SDL_SetVideoMode () from /usr/lib32/libSDL-1.2.so.0
#24 0x08346a96 in ?? ()
#25 0x08346211 in ?? ()


I'm using Arch Linux 64-bit. I installed the following packages:

    lib32-libgl
    lib32-mesa
    lib32-openal
    lib32-sdl

I'm using the open AMD graphic drivers:
Gallium 0.4 on AMD CAPE VERDE

Code: Select all

$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Chelsea XT GL [FirePro M4000]


Help would really be appreciated, I'd hate the idea that I've spent $45 for a game that does not work!
User avatar
Jimmeh
Forum Wrangler
Posts: 148
Joined: Wed Apr 11, 2007 5:09 pm
Location: Oxford

Re: [Linux] Segmentation Fault on start (Arch x86_64)

Postby Jimmeh » Mon Apr 28, 2014 6:10 pm

Hi,
We're looking in to this. If we can't fix it to your satisfaction we should be able to provide you with a refund.
freijon
Posts: 2
Joined: Fri Apr 25, 2014 7:21 pm

Re: [Linux] Segmentation Fault on start (Arch x86_64)

Postby freijon » Mon Apr 28, 2014 9:23 pm

Thanks, good to know.
If you need any further information, just let me know. I'm willing to help wherever I can.
feedback
Posts: 1
Joined: Fri Apr 27, 2012 10:12 pm

Re: [Linux] Segmentation Fault on start (Arch x86_64)

Postby feedback » Thu Nov 27, 2014 2:41 am

I’m experiencing the same problem. Has there been any progress on this issue?

Return to “Technical Support”

Who is online

Users browsing this forum: No registered users