Desync detected

Post bug reports here

Moderator: Admins

Post Reply
svendby
Posts: 1
Joined: Sat Jan 21, 2012 2:02 pm

Desync detected

Post by svendby » Sat Jan 21, 2012 2:07 pm

In game 448332 I am unable to submit my turn.

Every time I try I get a message saying:
"Desync detected.
Something went wrong, we need to reload."

What do I do?

Edit: After a few days it was suddenly all right. :)
TSPenguin
Posts: 1
Joined: Sun Feb 05, 2012 1:24 am

Re: Desync detected

Post by TSPenguin » Sun Feb 05, 2012 1:40 am

I suffer from the same problem in 3 games by now. I waited a few days to see if it will resolve itself as indicated by the OP, but I am suspecting he slightly changed his turn which did no longer trigger the desync detection.
Understandably, I do not want to alter my intended turns too much just to see which aspect triggers the desync but I varied them a lot with regards to timing and routes to no avail. However, it seems to have something to do with units escaping direct fire.

The game mode is dark extermination, game version is 28. (Installed from the humble FS bundle, installed zone hotfix then patch containing the auto update function)
Afflicted games are 454110, 456755 and 458697. I feel sorry for my opponents as they are waiting for my turns and I have no way of getting a message to them (yet?! *wink*)

Is there something wrong with the desync detection or does desyncing used to happen much more often than we suspected?
Wooglie
Posts: 5
Joined: Thu Jun 23, 2011 11:52 am

Re: Desync detected

Post by Wooglie » Wed Feb 08, 2012 1:37 pm

I get the same thing in 461283. Quite annoying that I can't continue my game.

Edit: I changed my turn slightly and it worked. I'm not sure, but I think it's to do with setting times without movements between them.
J.Mad
Posts: 26
Joined: Wed Dec 21, 2011 6:27 pm
Location: Upper Silesia, Poland
Contact:

Re: Desync detected

Post by J.Mad » Wed Feb 08, 2012 3:46 pm

I've got this bug in game 461257 vs DieOrFail. I try to use wait command in the bad turn (this is what Wooglie mind?), and I don't want to change my orders only to check if turn will go without error.
BrokenSynapse
Posts: 3
Joined: Thu Feb 09, 2012 5:11 pm

Re: Desync detected

Post by BrokenSynapse » Thu Feb 09, 2012 5:18 pm

A friend of mine got the same problem yesterday. He has the steam version. We did start 4 different games, but everytime he tried to end a turn he got the message: "Desync detected.
Something went wrong, we need to reload."

The solution was:

Go to Steam GamesLibrary, right click Frozen Synapse, go to "Properties -> Local Files -> Scan files for errors (don`t know the exact english phrase). After that, it worked - we could resume all the games.

Maybe it helps you guys too.
Post Reply