[Linux] Can't join multiplayer games

Bug reports and technical support for Frozen Cortex.

Moderator: Admins

Post Reply
Posts: 1
Joined: Sun Mar 06, 2016 8:50 pm

[Linux] Can't join multiplayer games

Post by NamelessOne » Sun Mar 06, 2016 8:56 pm

(I looked at existing threads and searched for my specific error, and couldn't find anything - let me know if this has been previously solved)

I have Frozen Cortex on Steam on Linux (Debian jessie on kernel 3.16.7), and I'm trying to play multiplayer with a friend. When I first installed the game, we managed to play a couple of games, and I also played against a few single player matches to get a feel for it.

Then, suddenly, joining a multiplayer match to play my first round, started crashing the game.

I also tried to verify the game cache through Steam, and tried again, with the exact same result.

These are the last lines in my ~/.local/share/FrozenCortex/console.log:

Code: Select all

GFXGLShader::initShader - Error compiling shader!
Program shaders/common/lighting/advanced/gl/pointLightP.glsl: Fragment shader failed to compile with the following errors:
ERROR: 15:419: error(#101) Macro redefined: SHADOW_DUALPARABOLOID_SINGLE_PASS
ERROR: error(#273) 1 compilation errors.  No code generated
I tried the game on Windows, and it worked perfectly.

Can anyone help me fix this?

EDIT: I just tried single player to see if the problem happens there as well. Curiously, in 5 attempts to play a single match versus AI, the game crashed 3 times. I checked the log after one of them, and I found the exact same error.

EDIT #2: I'm running fglrx 1:15.9-4~deb8u1 (ATi's proprietary driver), and my graphics card is a Radeon HD 7970 (R9 280X).
Post Reply