Multiple serious multiplayer issues in FS Prime

Bug reports and technical support for Frozen Cortex.

Moderator: Admins

Posts: 2
Joined: Sat Dec 03, 2016 10:51 pm

Multiple serious multiplayer issues in FS Prime

Postby val'ereth » Sat Dec 03, 2016 11:10 pm

I'm having a few serious problems playing multiplayer in Frozen Synapse Prime, and I'm not entirely sure how to resolve them.

The problems start when I try to create a game with a friend. When I try to create a game with a specific player (Adjust Settings -> change 'open' to a target player), and try to launch a game, I receive the message "No opponent found - We could not find you a match at this time..."; if I click 'cancel', I receive a message saying that I'm currently unable to log into the Frozen Synapse servers. But if I then back out of that message, I'm still shown as logged in, and I can even load+refresh the match list.

The way my friends and I tried to work around this was by creating an open match, which I could then join. However, when I try to do that, things go even more horrifically awry. I'm currently listed as being in four matches. The states of these matches are supposed to be:

- I've lost one of the matches, and have even tried resigning from it, but it still shows up with a status of "Play Now!" in the menu. The friend I'm playing against has /also/ tried resigning from this game, just to clear it from the match list, and this hasn't worked. It still shows up expecting my orders, even though all my units are dead, and I've been shown the game loss screen.
- One of the matches is listed as "Play Now!" I submitted orders last turn, and the turn was, actually, processed. However, my opponent's orders don't show up on my map. (It's not a dark game.) Their units just didn't move. From their side, mine didn't, either. But locally, our personal orders on both sides were processed. So we each see our respective units moving, and the others' units stationary. We stopped playing that match, out of confusion.
- In one of the games, both me and my opponent have primed orders, and we both see "Waiting for Opponent..." - however, the turn isn't processing, and the game is stuck in limbo.
- One of the matches was a test between me and another friend to try and figure out what's going on. We both primed an empty turn, just to see if it would process. It did, but I'm no longer able to prime orders on that game.

I normally have some clue as to where I could start debugging something like this, but this time, I genuinely have no idea.

How do I... fix these problems? Does anyone know what's going on?

Thanks in advance!
Posts: 2
Joined: Sat Dec 03, 2016 10:51 pm

Re: Multiple serious multiplayer issues in FS Prime

Postby val'ereth » Wed Dec 14, 2016 11:15 pm

I hate to bump posts, but I sent an email a week ago, and neither this post nor that email have been answered. Is this the correct place to request help with bug reports?

Return to “Technical Support”

Who is online

Users browsing this forum: No registered users